Copy Handler Community Forum

CH Support => General support => Topic started by: reddwarf on April 22, 2009, 10:33:49 am

Title: Copy fails on certain folders in Vista
Post by: reddwarf on April 22, 2009, 10:33:49 am
Hi There,

First I want to thank everybody that made this truly usefull application!

When I copy files to certain folders (examples would be "Program Files" and/or "Program Files (x86)") CH fails with an "Access is denied" error message.
If I then try to copy the same file to the same location but let Windows handle the copy action it asks for permission ("you'll need to provide administrator permission to copy to this folder"). If I then choose "Continue" the file gets copied. Must be part the whole UAC deal you get with Vista

No biggie (although it had me scratching my head for a couple of minutes), I kinda know now what folders need "normal" copy actions so I'm OK, but I thought to let you know of this issue. Perhaps this could be resolved in a future version.

Windows Vista x64
CH 1.31.185.0

Cheers,
Steven
Title: Re: Copy fails on certain folders in Vista
Post by: Ixen on June 07, 2009, 10:37:51 am
Hello,
For now there is one workaround and it is to run copy handler with administrative privileges.
The second solution would be to elevate CH privileges when trying to access the file that needs the higher permissions.
The first solution is obvious, the second however requires the CH process to be split to two parts as far as I remember. Somewhen in the future this functionality might appear, but not until CH is rewritten in a way that GUI will be completely separated from the core (which will run as a system service).

You can however put this feature request in the appropriate tracker on sourceforge.net.

Ixen
Title: Re: Copy fails on certain folders in Vista
Post by: reddwarf on June 08, 2009, 01:10:50 pm
Hi Ixen,

Thanks for the answers!

Cheers,
Steven