Copy fails from NTFS to EXT4 - Dialog "sure to copy without properties?" missing

Started by Parador, June 08, 2016, 07:24:10 PM

Previous topic - Next topic


Dear all,

I got a problem while trying to move files from NTFS to EXT4. Normally Windows ask's the user "Are you sure you want to copy this file without its properties?" but Copyhandler doesn't... the task fails and remains in the queue.
There is no dialog or something I can do...

It would be great if that dialog could be answered in the option with "yes" so everything would work ;-)

Thanks for your help/ideas!


How are you using ext4 with Windows - is it over samba share or some additional software?
Last time I checked, Windows did not support ext4 natively.


Yes, im moving files to my nas to a samba smb share, which is using ext4 as filesystem.


1. Is it possible for you to post the log for the task with such problems (either here or directly at ixen(a-t)copyhandler(d-o-t)com)?

2. Is there anything copied at all to the share or does the copying fail before even creating the first file?

I suspect here that there are problems with setting either the modification/creation time or specific attributes. As a simple test - you can change both of options:
- "Set attributes of destination files"
- "Set date/time of destination files"

to No and try to copy again (a new task as restarting existing one won't get the new configuration options). Please let me know the results.


Dear Ixen,

sorry I'm not everyday able to test so it could take some time till my next post.

1) Log-File.. I'm sorry I couldn't find the log file... please give me a hint (logs are activated in the options under debugging)
2) Yes often most of the files are copied - as I try at this moment... files are going through :-| (Bad for a report)
3) The actual (unchenged) settings of:
- "Set attributes of destination files"    - No
- "Set date/time of destination files"    - Yes
Today everything worked fine...


I'm not sure if that's good or bad news that everything is working :)
In the event you will encounter the problem again, please check the "View log" button on the task that is failing and please send me the displayed contents. Also please then check what had been copied (only directories? also some files?).
Right now I don't have enough data to work with (especially that I'm using CH to copy from/to samba shares on various filesystems and there is no such issue).


Sorry for "it worked last time" ;-)
It often fails after a few files. They stay at the queque...
I often move a few (3-7) folders with a few files (1-10).
If I try to restart it from the queque it fails again, if I copy it from the explorer directly it ask my for the properties...

But I will keep an eye on it and send you the log!

Thanks for the brainstorming ;-)

SMF spam blocked by CleanTalk