SMF - Just Installed!

Main Menu

Shell extension does not match version

Started by kattmarl, May 15, 2009, 11:58:58 PM

Previous topic - Next topic


I was running an older version of CH, and forgot to uninstall it before installing 1.31.  Now I can't get 1.31 working.

How can I unregister the OLD version?

I tried uninstalling the new version, rebooting, and then running regsvr32 /u chexe.dll, but it tells me it can't find the file.  Was the older version DLL named something different?

So then I installed the new version again, and I keep getting the "CH shell extension registered on your system does not match the Copy Handler version you are currently running.  Please reregister the shell extension.. and reboot... to make sure the proper version is loaded."

PLEASE HELP!!!  What can I do now?

~ Katt


Try just unregistering the current shell extension, then reboot and then install it again. This should help.



Thanks for the tip... but what is the executable I need to unregister?  Can you provide the file name?



Just check in the directory you have installed Copy Handler to. If I remember correctly it is chext.dll (or chext64.dll). In the very old versions the name was quite different. I can't remember it though.



first thank u for copy handler, great software
I was running CH v1.31 without any problem, when I update to v1.32 it does not register shell extension,
I even did a registry cleaning and no luck I install in another pc from scratch and it does not uses CH to copy/move files.

Is this version different in any way, Am I missing something ?

I tried register shell extension manually regsvr32 chext.dll and nothing.

greenting and keep up the good work
thanks again


This version should not differ in any way related to shell extension. Did you try to register using the CH menu option "Register shell extension"? What was the message?
Note that it is important after such manual registration to restart Copy Handler. Also if there was an old version at the same place, installer should have asked you to reboot the computer before installation could be finished (so it can properly replace the old version with new, and register it after replacing).



hello, thank u for your reply.

I tried to register using the CH menu option "Register shell extension" the messege was "library chext.dll ws registered successfully"
I restarted CH and I restarted the pc many times,

I think I will reinstall my windows xp again, for what you said I dont think is a CH problem

I'm using kaspersky, does it has anything to do with the problem ?

thanks again


It should not have. There were similar problems reported in the past, however I couldn't reproduce it. Usually after uninstalling, reboot and installing new version everything worked ok.


Ok, I will fix it anyway or the other, and let you know.


hello Ixen,

Bad news, I had to reinstall Windows for make CH v1.32 work,
I'm also sorry I could no be of help to this forum.

All the best

SMF spam blocked by CleanTalk